ESPresso Lite 2.0 Compilation Error

Bluetooth, XBee, RF......

ESPresso Lite 2.0 Compilation Error

Postby osman » Wed Apr 27, 2016 9:14 am

Hello everybody,

I compiled the Blink.ino sketch for the ESPresso board using Adruino 1.6.8 on an XP computer
and it gave me an error because it couldn't find a file named "bits/cxxabi_tweaks.h"

This is the full error message:
Code: Select all
Arduino: 1.6.8 (Windows XP), Board: "ESPresso Lite 2.0, 80 MHz, 115200, 4M (3M SPIFFS), ck, Disabled, None"

Build options changed, rebuilding all
In file included from C:\Documents and Settings\user\Local Settings\Application Data\Arduino15\packages\esp8266\hardware\esp8266\2.2.0\cores\esp8266\abi.cpp:23:0:

c:\documents and settings\user\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\cxxabi.h:50:32: fatal error: bits/cxxabi_tweaks.h: No such file or directory

 #include <bits/cxxabi_tweaks.h>

                                ^

compilation terminated.

exit status 1
Error compiling for board ESPresso Lite 2.0.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Can anyone help, where to get the missing file?
Thanks, in advance.

Osman
osman
Greenhorn
 
Posts: 2
Joined: Wed Apr 27, 2016 8:32 am

Re: ESPresso Lite 2.0 Compilation Error

Postby bengchet » Wed Apr 27, 2016 9:56 am

Hi,

Few suggestions:
1. Restart Arduino IDE and compile the sketch again.
2. You can try using Arduino IDE 1.6.7 instead of 1.6.8 which is a more stable version for now. Tested on Windows and Linux with no problem.

Please let us know the result. Thanks.
bengchet
Moderator
 
Posts: 237
Joined: Tue Aug 25, 2015 8:29 am

Re: ESPresso Lite 2.0 Compilation Error

Postby osman » Wed Apr 27, 2016 5:36 pm

Hi,

Thank you very much for your valuable suggestions.
I am now able to compile and load programs into the ESPresso,
except that I did that using Arduino IDE Version 1.6.5 and
ESP board manager version 2.2.0

I have tried IDE Versions 1.6.7 and 1.6.8 with board managers
versions 2.0.0, 2.1.0 and 2.2.0 without success. I guess my
computer is a bit too old. :-) but I will continue trying.

Anyway, since board manager version 2.2.0 is the latest, I guess
the compiled codes will also be the latest even though I am using
an older IDE.

Thank you, thank you, thank you,
especially for making this product available.

To fellow experimenters, happy ESPressing :-)
osman
Greenhorn
 
Posts: 2
Joined: Wed Apr 27, 2016 8:32 am

Re: ESPresso Lite 2.0 Compilation Error

Postby bengchet » Wed Apr 27, 2016 5:59 pm

Hi,

Fantastic!! Glad to hear that.

P/S: Dear visitors, this trick can be helpful on older OS such as Windows XP. We have tested later version up to Arduino IDE 1.6.8 on Windows 7, 8 and 10 without problem. If there are any new findings on installation, please do let us know. Once again, thanks and credit to Osman for sharing this trick!
bengchet
Moderator
 
Posts: 237
Joined: Tue Aug 25, 2015 8:29 am


Return to Wireless Device

Who is online

Users browsing this forum: No registered users and 4 guests

cron