Cytron ESP 8266 Shield Delaying

Bluetooth, XBee, RF......

Cytron ESP 8266 Shield Delaying

Postby Ian2024 » Wed Jun 19, 2019 3:47 pm

I'm using the wifi shield rev2 for a project which needs to run every 200hz. (1000 us per cycle). I realised that the shield is blocking my Arduino Uno when I try to send data to it through my phone. The delay is about 15000 us. It occurs even if I do not read for data from my wifi shield. I suspect its due to the interrupt in the wifi shield. How can I avoid this delay?

I've removed any code which reads for data from the wifi serial buffer. My code just calls wifi.begin and wifi.udpConnect which is a new function that I had written which works (I have tested it). The modified library I'm using can be found here: https://github.com/Ean244/CytronWiFiShield

How can I remove this delay? Thanks :)
Ian2024
Freshie
 
Posts: 5
Joined: Wed Oct 17, 2018 5:40 pm

Re: Cytron ESP 8266 Shield Delaying

Postby Ian2024 » Wed Jun 19, 2019 3:52 pm

Btw I have a few questions which may help me solve this issue.
1) How does the wifi shield work? Does it only attach the WROOM2 chip to the uno when I stack my uno on it? (eg it acts as a connector which connects uno with the wifi chip and does nothing else)
2) When uploading my program to Uno, is the program uploaded into Uno's bootloader or is it uploaded somewhere in the shield?
3) Does the shield run any implicit code which is not found in the library which may cause this delay?
Ian2024
Freshie
 
Posts: 5
Joined: Wed Oct 17, 2018 5:40 pm

Re: Cytron ESP 8266 Shield Delaying

Postby ZaM » Thu Jun 20, 2019 3:13 pm

1) How does the wifi shield work? Does it only attach the WROOM2 chip to the uno when I stack my uno on it? (eg it acts as a connector which connects uno with the wifi chip and does nothing else)
-This shield only act as logic level converter for WROOM2 chip.

2) When uploading my program to Uno, is the program uploaded into Uno's bootloader or is it uploaded somewhere in the shield?
-Code just uploaded into Arduino UNO not shield.

3) Does the shield run any implicit code which is not found in the library which may cause this delay?
-This one not sure
ZaM
Moderator
 
Posts: 70
Joined: Tue Nov 23, 2010 4:16 pm


Return to Wireless Device

Who is online

Users browsing this forum: No registered users and 12 guests

cron