[SOLVED] BlueBee 4.0 on Shield-XBEE Control Android Issue

Bluetooth, XBee, RF......

[SOLVED] BlueBee 4.0 on Shield-XBEE Control Android Issue

Postby tanloongpeng » Sun Jul 07, 2019 6:50 pm

Dear All,

I have enabled bluetooth on my Android phone and tried to pair to BlueBee. BlueBee default PIN number is 1234.
BlueBee in on top of Shield-XBee and D1 and DO are selected.

I have also refered to the user manual here --> https://tutorial.cytron.io/2015/10/08/g ... uebee-4-0/
I uploaded BlueBeeExample sketch to Arduino Board (Maker Uno).

I am able to control the LED Pin 7 Maker Uno using the COM5 of Arduino IDE. Light can be turn ON and Off using 1 and 0.
Then, I downloaded the "Bluetooth Terminal" App from Googleplay.

I then connected to the BlueBee 4.0 to my Phone successfully.
When I send 1 and 0, nothing happen to the LED 7 on Maker Uno.
Can you help see if I miss anything important in my script and why I am not able to control it using Android APP?

I have included the HM12.h library.

#include <HM12.h>
HM12 BlueBee(0,1);

I am out of idea why it is not working well.
WhatsApp Image 2019-07-07 at 8.46.59 PM.jpeg
Work OK with PC, connection successful, bluetooth is connected
WhatsApp Image 2019-07-07 at 11.39.01 PM.jpeg
Hardware connection
Posts: 4
Joined: Sun Jul 07, 2019 5:42 pm

Re: [SOLVED] BlueBee 4.0 on Shield-XBEE Control Android Issu

Postby tanloongpeng » Mon Jul 08, 2019 10:28 am

Following the testing by Zamzuri, I found that the baudrate for the BlueBee4.0 is different than the one in my Arduino code. We tested it using Bluetooth Terminal Connected to the BlueBee, with USB selected, jumper wire from GND to RESET. Then we type any character and open the serial monitor to see if we can get any character.

We did but it is all funny character. Then, we change baudrate until we can get the correct character.
Thank you Zamzuri for the help.
Posts: 4
Joined: Sun Jul 07, 2019 5:42 pm

Return to Wireless Device

Who is online

Users browsing this forum: No registered users and 3 guests