w5200 Ethernet shield pin attract to arduino

Servo Bracket, Robot Gripper, Robot Chasis, Micro Gearmotor Bracket, Castor,Acrylic, Anti-slip Map

w5200 Ethernet shield pin attract to arduino

Postby alung92 » Wed Oct 22, 2014 10:41 pm

i bought a W5200 Ethernet Shield from cytron, but that design is not allow to add port on above, that's why i solder it on another copper board use wire loop to arduino board then I connect 5v,D10,D11,D12,D13 using wire connect to arduino, but why it won't working? i cant connect to web server. If i use fully stack on it , it work. is that any idea ?
20141022_221654.jpg
alung92
Novice
 
Posts: 17
Joined: Thu Aug 21, 2014 12:57 pm

Re: w5200 Ethernet shield pin attract to arduino

Postby yonghui » Thu Oct 23, 2014 10:14 pm

Did u try connect the spi pin. There is connector beside the microsd for spi communication and 5v supply. Pls check whether the Ethernet part using spi.
thanks&regards,
yh
yonghui
Moderator
 
Posts: 732
Joined: Mon Sep 28, 2009 3:27 pm

Re: w5200 Ethernet shield pin attract to arduino

Postby kl84 » Mon Oct 27, 2014 4:25 pm

alung92 WROTE:but that design is not allow to add port on above, that's why i solder it on another copper board use wire loop to arduino board

I don't understand this part. Even the design doesn't have female headers at the top, you still can stack it on an Arduino main board isn't it?
User avatar
kl84
Amateur
 
Posts: 166
Joined: Thu Jul 08, 2010 12:14 pm

Re: w5200 Ethernet shield pin attract to arduino

Postby alung92 » Mon Oct 27, 2014 5:13 pm

Ya~ it don't have female header on top, that's a bad design, that y i need custom made, solder on another copper board. if not i cant connect analog and digital pins as well
alung92
Novice
 
Posts: 17
Joined: Thu Aug 21, 2014 12:57 pm

Re: w5200 Ethernet shield pin attract to arduino

Postby kl84 » Wed Oct 29, 2014 2:58 pm

I suspect it's due to loose connection, since you just use ordinary wires which may not fit nicely on Arduino's female headers.

Besides you can always refer to the schematic given to check if there's any missing connection.
User avatar
kl84
Amateur
 
Posts: 166
Joined: Thu Jul 08, 2010 12:14 pm


Return to Hardware

Who is online

Users browsing this forum: No registered users and 16 guests

cron