Page 1 of 1

Pic18f4550 connection problem with pickit3

PostPosted: Wed May 22, 2019 9:21 pm
by arunrawat2112
Hi I am new to ciku and after purchasing it i tried led blink with mplab and it worked perfectly. Now i have decided to use pickit3 for debugging puposes. But unfortunately the connection is not successful. It's not being recognized at all. Mplab IPE just says connection failed. Anyone can help me with this. Do i need to do some special button pressing tricks to connect it with pickit3 ?
Or do i have to flash some other bootloader ?

Re: Pic18f4550 connection problem with pickit3

PostPosted: Sat May 25, 2019 6:02 am
by ober
The connection failed to PICkit3 or to PIC18F4550? Mind sharing some printscreen and actual hardware setup?

If you use PICkit3, it will wipe out the bootloader for CIKU and you will have to use PICkit3 (or programmer) from that point on until you reload the bootloader into CIKU again. And to clarify, PICkit3 is a programmer, it does not require any bootloader to work.