Unable to get Dot Matrix Clock working properly

Please feedback the issue encountered while using Cytron official website (http://www.cytron.com.my), Cytron Technical Forum and Cytron Tutorial site (http://tutorial.cytron.com.my) here. We greatly appreciate any comments and suggestions too.

Unable to get Dot Matrix Clock working properly

Postby zhixiong86 » Fri May 01, 2020 7:39 am

Hi,

This is my first time getting a Arduino kit to star exploring it, however i'm having some issues.

I'm following https://tutorial.cytron.io/2019/10/23/d ... ing-esp32/ , it seems all pin are proper and setup are correct.

The dot matrix display seems to be not in the right order, what could be wrong? Please refer to pic. Thanks!
Attachments
WhatsApp Image 2020-05-01 at 07.38.12.jpeg
zhixiong86
Greenhorn
 
Posts: 2
Joined: Fri May 01, 2020 7:33 am

Re: Unable to get Dot Matrix Clock working properly

Postby Idris » Tue May 05, 2020 10:10 am

Hi zhixiong86,

Try to edit the code. Uncomment line 34 and comment line 35. In other words, try to #define HARDWARE_TYPE MD_MAX72XX::FC16_HW and program again. Please let me know the result. Thanks.
Cytron Technologies invest time and resources providing tutorial, training and support for STEM education and maker movement. We need your support by purchasing products from Cytron Technologies. Thanks.
http://www.cytron.com.my
User avatar
Idris
Moderator
 
Posts: 408
Joined: Thu Mar 22, 2012 5:28 pm
Location: Pulau Pinang

Re: Unable to get Dot Matrix Clock working properly

Postby zhixiong86 » Sun May 10, 2020 6:17 pm

Thanks, it working now!

Now I only manage to get it running after I upload the code from the Arduino IDE, how to make it work without reuploading?
zhixiong86
Greenhorn
 
Posts: 2
Joined: Fri May 01, 2020 7:33 am

Re: Unable to get Dot Matrix Clock working properly

Postby rodyeo » Sun Apr 11, 2021 12:30 am

zhixiong86 WROTE:Thanks, it working now!

Now I only manage to get it running after I upload the code from the Arduino IDE, how to make it work without reuploading?


Maybe can check my postings... https://m.facebook.com/story.php?story_ ... =554017662

You do not need to "Check/Compile" and "Upload" the code again... you only do it once and unplug the USB cable from the PC and plug it back to regular DC 5V adaptor and it will run but it self from the ESP32 programmed chip... I hope that tips helps....

*** Wait! the FTDI driver is not recognized by Windows Device Manager... FT231X USB UART driver is not installed yet! https://ftdichip.com/drivers/vcp-drivers/ [Select Windows Drivers!]

What to do if a non listed device in the Board Manager Library... add aditional board manager url link at ... Click 'File - Preferences', click the link below, copy the 'Stable release link' and paste it in 'Additional Boards Manager URLs'
CODE: SELECT_ALL_CODE
 https://github.com/espressif/arduino-esp32/blob/master/docs/arduino-ide/boards_manager.md

Then click 'Tools - Board - Board Manager...' Wait for a while for 'Downloading platform index'. Scroll down, install "esp32".

*** Important: Please download and use custom NTPClient v.3.1.0 Library Manager created by Idris @ Cytron.io only, else you will get error... "No Clock Time display on the Dot Matrix Display". https://github.com/taranais/NTPClient/a ... master.zip

Rodney @ http://rodyeo.dyndns.org
Attachments
Cyron-NTPClient-Custom-Library5.JPG
NTPClient v.3.10 Library Manager created by Idris @ Cytron.io
ESP32-add-board-mgr-urls.JPG
Additional Boards Manager URLs
esp32-dev-module.png
ESP32 Dev Module Board Manager selected
Include-Library-Add-ZIPLibrary.png
Include Library Add ZIP Library
Manage-Library.png
Manage Library
rodyeo
Fledgling
 
Posts: 1
Joined: Wed Feb 12, 2020 10:44 am


Return to Cytron Website, Forum & Tutorial Site Feedback

Who is online

Users browsing this forum: No registered users and 2 guests

cron