Inquiries For BL-02

Autonomous Robot, Manual Robot, DC Motor Driver, Stepper Motor Driver, Servo, Multi PWM chip.....

Inquiries For BL-02

Postby ken_alone » Fri Feb 10, 2012 10:40 pm

Hi everyone here, I have a a set of IFC card series. Yet, i'm encountering a problem lately, when i try writing a coding for BL-02 for my oriental motor, i find out that the encoder value for both motor 1 and motor 2 is different from what it should be. So now my situation was like this :
- i wrote a program on testing the encoder on BL-02 and the sequence is as below:
> Sw1 turn on both motor and move forwardly
> Encoder 2 will brake motor 2 when value of encoder is 1200. ( gear ratio 10 X 30 pulse per rotation for a round of wheel rotation)
> My problem start here.... My motor brake by value 1200, yet, my motor does not brake completely and it rotates with braking along.
> Then, it should be turn out with encoder 2 clear it's value.
> Followed by encoder 1, it is turned on with the same value 1200 which is 4 round of wheel.
> Though, my wheel is turned by 2 cycle and then the whole motor stop as planned.
> My 2nd problem here, the value of encoder is the same but the output came out is different, will it be the problem of the motor or card? Because when i swap both the motor, the situation is the same meaning it shouldn't be a problem with driver right?

So i hope to get some suggestion from you all....^^
ken_alone
Apprentice
 
Posts: 34
Joined: Thu Dec 31, 2009 3:40 pm

Re: Inquiries For BL-02

Postby robosang » Sat Feb 11, 2012 6:36 pm

Never use IFC before, just know it is from Cytron. But I saw several ROBOCON team uses it.

Your question is little confuse.

> Encoder 2 will brake motor 2 when value of encoder is 1200. ( gear ratio 10 X 30 pulse per rotation for a round of wheel rotation)

What is the motor output pulses? 30 or? Gear ratio 10, 30 pulses per wheel rotation or motor shaft? :?:

> My problem start here.... My motor brake by value 1200, yet, my motor does not brake completely and it rotates with braking along.

What do you mean by rotates with braking along? The wheel still rotate, slowly or normal speed as before?

Don know whether is card problem or code problem, cannot help much. How is the code look?
robosang
Expert
 
Posts: 1239
Joined: Wed Jun 10, 2009 5:37 pm

Re: Inquiries For BL-02

Postby yonghui » Sat Feb 11, 2012 10:20 pm

im confused with the statement of problems also.

did u slow down the motor when the encoder value is near to desired value so that the motor can stop without overshoot when the econder value reached?

rgds,
yh
thanks&regards,
yh
yonghui
Moderator
 
Posts: 732
Joined: Mon Sep 28, 2009 3:27 pm

Re: Inquiries For BL-02

Postby ken_alone » Sun Feb 12, 2012 3:01 am

Hi there.....
Robosang : the 10 X 30 came out with the encoder value of 300 for the my wheel to turn a round. My meaning for turning along braking means that the robot brake, yet with unknown reason, the wheel still stretchable by force if i try it with moving left motor. ( when free run the situation is correct, which is motor left turn while motor 2 brake) but the real situation is motor 2 that should be brake stretched with the turning left motor with a small range of speed.

YH : The motor should be brake, the motor should work with a full speed with my specified encoder value. Then, it should be brake after that. But some how, the motor that brake in free run stretched to move by the other side motor. So i wonder how it would be?
ken_alone
Apprentice
 
Posts: 34
Joined: Thu Dec 31, 2009 3:40 pm

Re: Inquiries For BL-02

Postby robosang » Mon Feb 13, 2012 8:48 am

ken_alone WROTE:Hi there.....
Robosang : the 10 X 30 came out with the encoder value of 300 for the my wheel to turn a round. My meaning for turning along braking means that the robot brake, yet with unknown reason, the wheel still stretchable by force if i try it with moving left motor. ( when free run the situation is correct, which is motor left turn while motor 2 brake) but the real situation is motor 2 that should be brake stretched with the turning left motor with a small range of speed.


You need to write in proper method, not everyone here familiar with all the thing being asked, even Cytron staff don know all. :lol: Most of us are not Cytron staff, just some busy body trying to shoot someone, so please explain in "undestandable" way. :mrgreen: So 1200 pulses is expected from the motor if the motor turn 4 rotation, is that correct? Brake in motor is still turnable by external force. Normally brake condition have relatively stronger holding torque compare to stop condition. There is no braking mechanical parts in normal motor like bicycle or motorcycle where you can really apply braking force with brake paddle. In short, brake should have better holding torque than stop, but it is still be turn with strong external force.

Again, really don know what you mean by left motor and motor 2, for me this is very confusing. Either you use motor 1, motor 2, motor 3, OR left motor and right motor. You are mixing up the label. Are you sure you are not doing it when you write program? Maybe the label is causing all this problem.

I would say high possibility is coding issue......
robosang
Expert
 
Posts: 1239
Joined: Wed Jun 10, 2009 5:37 pm


Return to Robot Controller

Who is online

Users browsing this forum: No registered users and 1 guest

cron