Failed to use stepper motor driver.

Autonomous Robot, Manual Robot, DC Motor Driver, Stepper Motor Driver, Servo, Multi PWM chip.....

Failed to use stepper motor driver.

Postby winson27 » Thu Nov 15, 2012 7:41 pm

Referring to the topic above, I failed to drive my stepper motor with the driver. If I don't use UART, by sending pulse of 1000 ms into the pulse port, nothing happen? On and Off continuosly, what should i send in to control the rotation of stepper motor?? If I want to use arduino digital port like port 13 to send in the pulse, what kind of pulse or program should i use? Need help in urgent, Thanks.
winson27
Freshie
 
Posts: 7
Joined: Mon Apr 02, 2012 10:27 pm

Re: Failed to use stepper motor driver.

Postby zhenning » Thu Nov 15, 2012 8:28 pm

Have you check out the arduino stepper motor library: http://arduino.cc/en/Reference/Stepper :)
zhenning
Enthusiast
 
Posts: 351
Joined: Thu Dec 30, 2010 12:32 am

Re: Failed to use stepper motor driver.

Postby winson27 » Fri Nov 16, 2012 8:41 am

But, now I am using SD02B and there's only 1 port for me to send in the pulse(not tx and rx), and after I read the user manual, I tried to send in the blinking pulse but the motor runs out of control, its like totally slipping, very high speed no matter what pulse I change~
winson27
Freshie
 
Posts: 7
Joined: Mon Apr 02, 2012 10:27 pm

Re: Failed to use stepper motor driver.

Postby robosang » Fri Nov 16, 2012 10:09 am

Do this motor driver have button for fast testing?
robosang
Expert
 
Posts: 1239
Joined: Wed Jun 10, 2009 5:37 pm

Re: Failed to use stepper motor driver.

Postby Alen.ATLow » Fri Nov 16, 2012 10:44 am

Slipping ?
Normal for stepper motor slipping, I check ->

Stepper motor coil resistance
Stepper motor phase wiring - Most likely
Stepper motor sizing (is it undersized ?)
Alen.ATLow
Novice
 
Posts: 17
Joined: Mon Nov 12, 2012 12:53 pm

Re: Failed to use stepper motor driver.

Postby sich » Fri Nov 16, 2012 5:41 pm

You can press the TEST button on SD02B to test the driver. Most likely it's because of wrong wiring. Can you follow the instruction in SD02B user manual to determine the wiring sequence? Another possible reason is the pulse you sent is higher than the working frequency of your stepper motor. Try keep it at very low rate first.
~> How to ask QUESTIONS the SMART way in FORUM? <~
User avatar
sich
Moderator
 
Posts: 603
Joined: Tue Apr 21, 2009 2:15 pm

Re: Failed to use stepper motor driver.

Postby winson27 » Sat Nov 17, 2012 12:40 am

The wiring is correct coz when i press the test button, it runs normally. Can you pls suggest a program of arduino uno for me? Which can be used to trigger the "Pulse Port" of SD02B. Thanks alot.
winson27
Freshie
 
Posts: 7
Joined: Mon Apr 02, 2012 10:27 pm

Re: Failed to use stepper motor driver.

Postby shahrul » Sun Nov 18, 2012 4:44 pm

For starting, you put pulse at low frequency or that means you give higher delay for the pulse.
Ex stepper motor driver.
User avatar
shahrul
Professional
 
Posts: 812
Joined: Sat May 16, 2009 9:54 pm
Location: Selangor

Re: Failed to use stepper motor driver.

Postby sich » Mon Nov 19, 2012 2:03 pm

Did you tie EN pin to 5V and DIR pin to either 0V or 5V? Or you left the pins floating?
~> How to ask QUESTIONS the SMART way in FORUM? <~
User avatar
sich
Moderator
 
Posts: 603
Joined: Tue Apr 21, 2009 2:15 pm

Re: Failed to use stepper motor driver.

Postby winson27 » Tue Nov 20, 2012 12:01 am

my EN pin must connect to 5V (even i don't want the motor shaft to be hold) and DIR must 0V or 5V? floating of these 2 will cause problem?
winson27
Freshie
 
Posts: 7
Joined: Mon Apr 02, 2012 10:27 pm

Next

Return to Robot Controller

Who is online

Users browsing this forum: No registered users and 2 guests

cron