Page 1 of 1

Issue with MD10C and Arduino Uno

PostPosted: Tue Sep 02, 2014 10:58 pm
by Kstuck
First off let me say I really like the MD10C and I'm sure what happened is something I did but I can't seem to locate where I did anything incorrectly.

As soon as I flipped the power switch on for the 9v it burned out something on the Vin on the Uno side. The only way the Uno now powers up is by connecting the computer to it.

I had everything working correctly without the MD10C connected. I used an external 9v connected to the Vin pin on the Uno but the MD10C was not in the circuit.

I don't really care about the Uno I just want to make sure I don't roast another one.

Any thoughts?

My first thought was to run the Uno off it's own power source but I'm a little unsure how to connect everything if I have two sources with two different voltages. One source for the Uno at 6 - 9 volts going into the Vin pin and one source for the MD10C at 9 - 12 volts with the logic grnd connected to the Arduino ground. I experimented around with this a little and every time I connected the wire from the MD10C logic ground to the ground on the Uno the regulated 5v out from the Arduino would start fluctuating enough to effect the output from the pots connected to the 5v source.

Any thoughts on this?

This is my wiring diagram Sorry it's probably a little hard to read.


Any thoughts would be appreciated.

Re: Issue with MD10C and Arduino Uno

PostPosted: Wed Sep 03, 2014 3:46 am
by Kstuck

Re: Issue with MD10C and Arduino Uno

PostPosted: Wed Sep 03, 2014 1:33 pm
by waiweng83
That's very weird as your connection diagram looks correct.

May I know what is the power source for the 12V?
What is the voltage on the 9V battery when you power on the circuit?
Can you please capture a photo showing the connection of your system?

Re: Issue with MD10C and Arduino Uno

PostPosted: Thu Sep 04, 2014 3:09 am
by Kstuck
Thanks for the help.

I can get some pictures tonight.

The 12V power is from an 18AH sealed lead acid Werker WKA12-18NB battery. The battery is a few years old but it's fully charged.

The 9V is just from a 9V battery. I tried changing the 9V battery to several different new 9V batteries but I never measured the voltage.

I'm wondering if it might have been the Uno. The Uno came off another project that my daughter and I had been working on and I wonder if it may have been damaged on that project and it just showed up when I did this.

I have an older mega that I don't really care about that I might hook up and try just to see what happens.

Thanks again!

Re: Issue with MD10C and Arduino Uno

PostPosted: Fri Sep 05, 2014 12:31 am
by Kstuck
I just went ahead and tried it with the Arduino Mega and everything worked great.

Must be an issue with the Uno I was using.

Thanks for all of your help!

Re: Issue with MD10C and Arduino Uno

PostPosted: Fri Sep 05, 2014 2:14 pm
by ober
Good to hear that. You are welcome to share your project here!