MDD10A/ Raspberry pi

Autonomous Robot, Manual Robot, DC Motor Driver, Stepper Motor Driver, Servo, Multi PWM chip.....

MDD10A/ Raspberry pi

Postby sflynn218 » Tue Sep 06, 2016 4:12 am

So I am trying to use the MDD10A with the raspberry pi to control two motors. I am having two problems which very well could be related. First of all, when changing the duty cycle the motors whine and make a lot of noise that can not be normal.

Second, after connecting a Oscilloscope, I saw the waveform going out of the pie was a normal PWM signal. The waveform or signal coming out of the MDD10A board had pulses within the PWM pulse. Is this normal, and could it be causing my issues with the motors.

I have tried using different frequencies and nothing seemed to get rid of that noise. Any help would be appreciated.

I am using:

-12V 10 A battery

-Motor: Ampflow P40-250 250W 24V Motor (At 12V, 125W)

-MDD10A (obviously)

-Raspberry Pi (Obviously)

* See setup2 and setup3 photos


Steven Flynn
sflyn218@yahoo.com
Attachments
Just_MDD10A-min.jpg
Shows just the MDD10A output signal
RasPi_and_MDD10A-min.jpg
Shows the Raspberry pi signal ad the MDD10A signal. (Raspberry pi is on top)
setup2-min.jpg
setup3-min.jpg
sflynn218
Greenhorn
 
Posts: 2
Joined: Tue Sep 06, 2016 3:29 am

Re: MDD10A/ Raspberry pi

Postby ober » Thu Sep 08, 2016 9:36 am

Is quite common for high current motor to interfere with the controller or driver.

Can you show the connection to your Raspberry Pi?

Also the motor seem to have very huge start up current, the battery and motor driver might not be suitable for it.
Ober Choo
Cytron Technologies Sdn Bhd
www.cytron.com.my
User avatar
ober
Moderator
 
Posts: 1365
Joined: Wed Apr 15, 2009 1:03 pm

Re: MDD10A/ Raspberry pi

Postby sflynn218 » Sat Sep 10, 2016 8:56 pm

the motor driver has the same signal output whether or not the motor is connected or not

The current is something i was very worried about however without a load the motor pulls about 1-2 Amps which should not be a problem.

See attachments for the requested pictures
Attachments
20160910_084517.jpg
20160910_084501.jpg
20160910_084422.jpg
sflynn218
Greenhorn
 
Posts: 2
Joined: Tue Sep 06, 2016 3:29 am

Re: MDD10A/ Raspberry pi

Postby Geeva » Tue Sep 19, 2017 12:44 pm

I am also facing same issue, Can you Answer how to solve this noise issue ?
Geeva
Fledgling
 
Posts: 1
Joined: Tue Sep 19, 2017 12:39 pm


Return to Robot Controller

Who is online

Users browsing this forum: No registered users and 3 guests

cron