problem checking two cards MD20a with pixhawk

Autonomous Robot, Manual Robot, DC Motor Driver, Stepper Motor Driver, Servo, Multi PWM chip.....

problem checking two cards MD20a with pixhawk

Postby fabio » Sat Jul 27, 2019 8:13 pm

Thanks for your time, I am converting a robot mower with a pixhawk controller. I can't send a signal when I use 2 cards at the same time. one individually works, two become "deaf". the wiring looks correct, do you have ideas? on pixhawk is loaded ardurover 3.5.1 and is set as a robot with 2 engines to turn and advance.

ideas on what i can try? one thing, trying with a servo test I can't control the MD20a card, how come?
Attachments
20190727_140720.jpg
tagliaerba
fabio
Fledgling
 
Posts: 1
Joined: Sat Jul 27, 2019 7:49 pm

Re: problem checking two cards MD20a with pixhawk

Postby ober » Mon Jul 29, 2019 8:42 am

Not really familiar with Pixhawk, so need more info on the output signal from Pixhawk and the detailed wiring.

Looking at the sepc of MD20A, it accepts lock anti-phase or signed magnitude signal from controller, so since you can use it (at least single board) with Pixhawk, I am assuming the output signal from Pixhawk is correct, but further verification might be needed.

Detailed wiring is necessary for us to help, just hand drawing is fine.
Ober Choo
Cytron Technologies Sdn Bhd
www.cytron.com.my
User avatar
ober
Moderator
 
Posts: 1455
Joined: Wed Apr 15, 2009 1:03 pm


Return to Robot Controller

Who is online

Users browsing this forum: No registered users and 1 guest

cron