G15 : Error 'E00' in hex or '3584' in decimal

LINIX Brushless, VEXTA Brushless, RC Servo, DC Geared, Linear, Stepper, Tamiya.....

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby yewys » Thu Apr 27, 2017 4:04 pm

Hi,

I tried to extract a new arduino ide file and using it i can move my motor FINALLY! i think my libraries in the old ide folder is messed up already, which may be cause of all these problems before.
Okay, so now i can play around with arduino. Other than arduino, do you know on how to program the g15 servo in labview so that they (motors) can understand and follow the commands?
yewys
Novice
 
Posts: 20
Joined: Sun Apr 09, 2017 10:18 pm

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby yonghui » Thu Apr 27, 2017 4:53 pm

Glad to hear that you successfully solve the problem with the library. Congratulations!

. Other than arduino, do you know on how to program the g15 servo in labview so that they (motors) can understand and follow the commands?


can you try to find if Labview can send commands using Serial interface? if can then u can just send out the angles that u want to Arduino through the USB-UART virtual Serial COM. Then let Arduino process and set the angle and command G15 to move the desired position.

LABView-->virtual Serial com-->Arduino-->G15-Shield-->G15 Cube Servo.

arduino itself will emulate as virtual serial com when you connect it to computer.

maybe you try watch this video.
https://www.youtube.com/watch?v=P1NSdbzkNR4
https://www.youtube.com/watch?v=VpxBTtvCklo
not sure it will be helpful to you or not.
thanks&regards,
yh
yonghui
Moderator
 
Posts: 732
Joined: Mon Sep 28, 2009 3:27 pm

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby yewys » Thu Apr 27, 2017 5:07 pm

Hi yonghui & A380,

yonghui, thanks for your link.

Thank you guys for helping me up till now. Appreciate that, will ask question if i'm facing any in the future. :lol: :lol:
yewys
Novice
 
Posts: 20
Joined: Sun Apr 09, 2017 10:18 pm

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby Ravinath » Thu Dec 21, 2017 1:51 am

yonghui WROTE:Glad to hear that you successfully solve the problem with the library. Congratulations!

. Other than arduino, do you know on how to program the g15 servo in labview so that they (motors) can understand and follow the commands?


can you try to find if Labview can send commands using Serial interface? if can then u can just send out the angles that u want to Arduino through the USB-UART virtual Serial COM. Then let Arduino process and set the angle and command G15 to move the desired position.

LABView-->virtual Serial com-->Arduino-->G15-Shield-->G15 Cube Servo.

arduino itself will emulate as virtual serial com when you connect it to computer.

maybe you try watch this video.
https://www.youtube.com/watch?v=P1NSdbzkNR4
https://www.youtube.com/watch?v=VpxBTtvCklo
not sure it will be helpful to you or not.


hye..is it possible to run the g15 motor only with myrio without using arduino??
Ravinath
Newbie
 
Posts: 13
Joined: Sun Nov 19, 2017 4:14 pm

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby Ravinath » Thu Dec 21, 2017 1:55 am

yewys WROTE:Hi,

I've tried to run the servo motors using arduino shield and it works! But how come it doesn't work when using GD-02 driver? I've even bought a new GD-02 Rev2.0 to test but still the same, motors don't move :(
May someone teach me on how to write coding referring to the g15 source code, please?


hye for gd02 rev2.0 the connections for rx and tx are different. u have to connect the rx of arduino to tx of driver and tx of arduino to rx of driver.
Ravinath
Newbie
 
Posts: 13
Joined: Sun Nov 19, 2017 4:14 pm

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby Ravinath » Mon Mar 05, 2018 10:23 pm

Ravinath WROTE:
yewys WROTE:Hi,

I've tried to run the servo motors using arduino shield and it works! But how come it doesn't work when using GD-02 driver? I've even bought a new GD-02 Rev2.0 to test but still the same, motors don't move :(
May someone teach me on how to write coding referring to the g15 source code, please?


hye can you help me how to run the g15 servo with shield?thanks
Ravinath
Newbie
 
Posts: 13
Joined: Sun Nov 19, 2017 4:14 pm

Re: G15 : Error 'E00' in hex or '3584' in decimal

Postby Idris » Tue Mar 06, 2018 9:24 am

Hi Ravinath,

Ravinath WROTE:hye can you help me how to run the g15 servo with shield?thanks

You can refer to GETTING STARTED WITH CYTRON G15 SHIELD (REV 2.0) tutorial. Hope this helps.

Thanks.
Cytron Technologies invest time and resources providing tutorial, training and support for STEM education and maker movement. We need your support by purchasing products from Cytron Technologies. Thanks.
http://www.cytron.com.my
User avatar
Idris
Moderator
 
Posts: 384
Joined: Thu Mar 22, 2012 5:28 pm
Location: Pulau Pinang

Previous

Return to DC Motor

Who is online

Users browsing this forum: No registered users and 2 guests

cron