Problem related to FD04A 2.0

FYP Starter Pack, ICs, Voltage Regulator, Resistor, Capacitor......

Problem related to FD04A 2.0

Postby aster123 » Thu May 17, 2018 11:17 am

it seems that the 4 channel motor driver i recently brought seems to have a problem. the 4 channel motor driver is connected to the arduino to control all 4 motor. but when i turn on the arduino with 7V power connected through a buck boost converter while the 12 V is connected to the motor driver both power source originate from the same 12V battery. the motor driver seems to turn on it self even when the switch is in off mode. i even manage to control the motor with the switch in off mode. this did never occur before when i use power bank to powered the arduino while the motor driver is powered by 12V lipo battery. is this normal? need help here.

besides that, the motor driver is connected to a 12V battery with a reading of 12.5V in the input of the motor driver. but the motor driver produced an output of only 10.5V at full speed. is this normal?
aster123
Freshie
 
Posts: 6
Joined: Thu May 17, 2018 11:00 am

Re: Problem related to FD04A 2.0

Postby Idris » Thu May 17, 2018 2:53 pm

Hi aster123,

Could you share a few clear photos of your hardware setup?
Cytron Technologies invest time and resources providing tutorial, training and support for STEM education and maker movement. We need your support by purchasing products from Cytron Technologies. Thanks.
http://www.cytron.com.my
User avatar
Idris
Moderator
 
Posts: 379
Joined: Thu Mar 22, 2012 5:28 pm
Location: Pulau Pinang

Re: Problem related to FD04A 2.0

Postby aster123 » Thu May 17, 2018 3:09 pm

here the pic
Attachments
pic2.jpg
aster123
Freshie
 
Posts: 6
Joined: Thu May 17, 2018 11:00 am

Re: Problem related to FD04A 2.0

Postby aster123 » Thu May 17, 2018 3:24 pm

second pic\
Attachments
pic1.jpg
aster123
Freshie
 
Posts: 6
Joined: Thu May 17, 2018 11:00 am

Re: Problem related to FD04A 2.0

Postby ober » Fri May 18, 2018 4:58 pm

Is the 5V of FD04A being connected to Arduino's 5V?
Ober Choo
Cytron Technologies Sdn Bhd
www.cytron.com.my
User avatar
ober
Moderator
 
Posts: 1436
Joined: Wed Apr 15, 2009 1:03 pm

Re: Problem related to FD04A 2.0

Postby aster123 » Fri May 18, 2018 6:38 pm

Yes. The GND and 5v from fd04a is connected to the Arduino based on the tutorial
aster123
Freshie
 
Posts: 6
Joined: Thu May 17, 2018 11:00 am

Re: Problem related to FD04A 2.0

Postby Idris » Mon May 21, 2018 4:22 pm

Hi aster123,

5V pin at FD04A is a supply out. So if you connect 5V pin to Arduino, make sure your Arduino is not connected to any power source (like adapter/battery/USB). Could you confirm that first?

Thanks.
Cytron Technologies invest time and resources providing tutorial, training and support for STEM education and maker movement. We need your support by purchasing products from Cytron Technologies. Thanks.
http://www.cytron.com.my
User avatar
Idris
Moderator
 
Posts: 379
Joined: Thu Mar 22, 2012 5:28 pm
Location: Pulau Pinang

Re: Problem related to FD04A 2.0

Postby aster123 » Tue May 22, 2018 10:11 am

yes. i just notice that and burn 1 of my arduino. but why is the cytron people selling product without any guide on how to operate them. they only showed me the old tutorial for rev 1 and not rev 2. because of that 1 of my arduino was burn. i like this product but it seems that they are not updating their tutorial which is missguided and causes me to burn a few arduino
aster123
Freshie
 
Posts: 6
Joined: Thu May 17, 2018 11:00 am

Re: Problem related to FD04A 2.0

Postby Idris » Tue May 22, 2018 3:37 pm

Hi aster123,

Did you read the FD04A R2 User's Manual before operate it? I'm not sure how the driver can spoilt your Arduino. If you bought the Arduino board from us, you can fill up Support form, our support team will guide you for warranty process.

Hope this help, thanks. :)
Cytron Technologies invest time and resources providing tutorial, training and support for STEM education and maker movement. We need your support by purchasing products from Cytron Technologies. Thanks.
http://www.cytron.com.my
User avatar
Idris
Moderator
 
Posts: 379
Joined: Thu Mar 22, 2012 5:28 pm
Location: Pulau Pinang

Re: Problem related to FD04A 2.0

Postby aster123 » Tue May 22, 2018 5:43 pm

i did read the user manual. and i also request for tutorial. but they seems to offer me a link on the old model rev 1 tutorial which mention that u need to connect 5V and gnd from the driver to the arduino while the arduino is receiving power from the power adapter.
aster123
Freshie
 
Posts: 6
Joined: Thu May 17, 2018 11:00 am

Next

Return to Electronic Component

Who is online

Users browsing this forum: No registered users and 1 guest

cron