adc value for IMU

Digital Fiber, Photoelectric, Laser Range, Optical, Temperature, Rotary Encoder, Ultrasonic, Gas, Gyro, Accelerometer, FlexiBend, Flexiforce, Compass......

Re: adc value for IMU

Postby aurora » Sun Jan 24, 2010 6:04 pm

Have you check the voltage out from the IMU using multimeter?

Could it be the USART communication problem? Try disable the analog in accelero_x, y and z, and substitute with constant. If it's ok, try using a potentiometer as voltage divider and see if it read properly.
aurora
Discoverer
 
Posts: 126
Joined: Sun Jun 07, 2009 4:52 pm

Re: adc value for IMU

Postby A380 » Tue Jan 26, 2010 4:20 pm

May I know what compiler you use and what library you use to call this function --> set_ADC_channel(5);?

My advise here, may be you can use a potential meter or rheostat to test your ADC is working or not.
User avatar
A380
Discoverer
 
Posts: 119
Joined: Tue May 19, 2009 2:44 pm
Location: Malaysia

Re: adc value for IMU

Postby watisthis » Thu Jan 28, 2010 9:59 pm

i already try using pot.meter, same result
using PCW compiler,
the library for the function is in device->Pic16f877a
watisthis
Newbie
 
Posts: 10
Joined: Sun Jan 03, 2010 3:28 pm

Re: adc value for IMU

Postby aurora » Fri Jan 29, 2010 12:56 am

From the code, don't think there is any problem with it. No warning/error message right?

I'm using PCW compiler also. Haven't had any problem reading with my project. I use 16-pin type LCD, not serial, I'm using 8-bit though...

Try sending fix value to your lcd this time. Let accelero_x, y, z be some value, say 1, 501, 1001. See if you can read in your LCD.
aurora
Discoverer
 
Posts: 126
Joined: Sun Jun 07, 2009 4:52 pm

Previous

Return to Sensor

Who is online

Users browsing this forum: No registered users and 2 guests

cron