Pic18f4550 connection problem with pickit3

Discussion about projects that used PIC Microcontroller, Hardware Interface, Programming Algorithm and etc......

Pic18f4550 connection problem with pickit3

Postby arunrawat2112 » Wed May 22, 2019 9:21 pm

Hi I am new to ciku and after purchasing it i tried led blink with mplab and it worked perfectly. Now i have decided to use pickit3 for debugging puposes. But unfortunately the connection is not successful. It's not being recognized at all. Mplab IPE just says connection failed. Anyone can help me with this. Do i need to do some special button pressing tricks to connect it with pickit3 ?
Or do i have to flash some other bootloader ?
Posts: 1
Joined: Wed May 22, 2019 9:16 pm

Re: Pic18f4550 connection problem with pickit3

Postby ober » Sat May 25, 2019 6:02 am

The connection failed to PICkit3 or to PIC18F4550? Mind sharing some printscreen and actual hardware setup?

If you use PICkit3, it will wipe out the bootloader for CIKU and you will have to use PICkit3 (or programmer) from that point on until you reload the bootloader into CIKU again. And to clarify, PICkit3 is a programmer, it does not require any bootloader to work.
Ober Choo
Cytron Technologies Sdn Bhd
User avatar
Posts: 1473
Joined: Wed Apr 15, 2009 1:03 pm

Return to PIC Microcontroller

Who is online

Users browsing this forum: No registered users and 1 guest